silverstripe/framework's URL parameters isDev and isTest unguarded
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/framework 4.1.1, 4.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/framework
- Affected
- >= 4.0.0-rc1, < 4.0.4>= 4.1.0rc1, < 4.1.1
- Fixed in
- 4.1.1, 4.0.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-55qg-6c4m-mw6g lists affected ranges: Packagist silverstripe/framework >=4.0.0-rc1 =4.1.0rc1 <4.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The URL parameters isDev and isTest are accessible to unauthenticated users who access a SilverStripe website or application. This allows unauthorised users to expose information that is usually hidden on production environments such as verbose errors (including backtraces) and other debugging tools only available to sites running in "dev mode". Core functionality does not expose user data through these methods. Depending on your website configuration, community modules might have added more specific functionality which can be used to either access or alter user data. We have fixed the usage of isDev and isTest in SilverStripe 4.x, and removed the URL parameters in the next major release of SilverStripe.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-55qg-6c4m-mw6g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-55qg-6c4m-mw6g Advisory: silverstripe/framework's URL parameters `isDev` and `isTest` unguarded IDs: GHSA-55qg-6c4m-mw6g Record: https://patchnext.com/advisories/ghsa-55qg-6c4m-mw6g (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/framework 4.1.1, 4.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/framework: affected >= 4.0.0-rc1, < 4.0.4; >= 4.1.0rc1, < 4.1.1; fixed in 4.1.1, 4.0.4 ## Suggested inspection (read-only) - Packagist silverstripe/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-55qg-6c4m-mw6g (GitHub-reviewed advisory GHSA-55qg-6c4m-mw6g lists affected ranges: Packagist silverstripe/framework >=4.0.0-rc1 =4.1.0rc1 <4.1.1) Commands are suggestions: review each one before running it.
Loading voting…