Vulnerable OpenSSL included in cryptography wheels
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cryptography 48.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI cryptography
- Affected
- >= 0.5.0, < 48.0.1
- Fixed in
- 48.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-537c-gmf6-5ccf lists affected ranges: PyPI cryptography >=0.5.0 <48.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-537c-gmf6-5ccf lists affected ranges: PyPI cryptography >=0.5.0 <48.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in wheels prior to cryptograph 48.01 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://openssl-library.org/news/secadv/20260609.txt. If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-537c-gmf6-5ccf
- Revision 1 · created ·
Published from osv record GHSA-537c-gmf6-5ccf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-537c-gmf6-5ccf Advisory: Vulnerable OpenSSL included in cryptography wheels IDs: GHSA-537c-gmf6-5ccf Record: https://patchnext.com/advisories/ghsa-537c-gmf6-5ccf (revision 2, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cryptography 48.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI cryptography: affected >= 0.5.0, < 48.0.1; fixed in 48.0.1 ## Suggested inspection (read-only) - `python -m pip show cryptography`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cryptography. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-537c-gmf6-5ccf (OSV record GHSA-537c-gmf6-5ccf lists affected ranges: PyPI cryptography >=0.5.0 <48.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-537c-gmf6-5ccf (GitHub-reviewed advisory GHSA-537c-gmf6-5ccf lists affected ranges: PyPI cryptography >=0.5.0 <48.0.1) Commands are suggestions: review each one before running it.
Loading voting…