Kimai has an XXE Leading to Local File Read
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kimai/kimai 2.21.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist kimai/kimai
- Affected
- <= 2.20.1
- Fixed in
- 2.21.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-534c-hcr7-67jg lists affected ranges: Packagist kimai/kimai >=0 <=2.20.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Kimai uses PHPSpreadsheet for importing and exporting invoices. Recently, a CVE was identified in PHPSpreadsheet, which could lead to an XXE vulnerability. Details Exploitation requires an Administrator account, allowing the upload of an XLSX template containing the payload. The vulnerability is triggered by the following code snippet: The IOFactory::load function utilizes simplexmlloadstring, which has previously been demonstrated to be vulnerable to XXE attacks. While this is not directly an XXE in Kimai, it does however impact the latest stable version. PoC By uploading a malicious XLSX template, the payload will be triggered every time an invoice is generated. For a better a visibility, I will upload both a: - Malicious template sample for testing - An exported invoice, showing the contents of target file during the export. Impact Local File Read / RCE in edge cases where phar:// can be utilized with gadget chains . export.xlsx sampletemplate.xlsx
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-534c-hcr7-67jg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-534c-hcr7-67jg Advisory: Kimai has an XXE Leading to Local File Read IDs: GHSA-534c-hcr7-67jg Record: https://patchnext.com/advisories/ghsa-534c-hcr7-67jg (revision 1, source checked 26 Oct 2026, 14:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kimai/kimai 2.21.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist kimai/kimai: affected <= 2.20.1; fixed in 2.21.0 ## Suggested inspection (read-only) - Packagist kimai/kimai: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kimai/kimai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-534c-hcr7-67jg (GitHub-reviewed advisory GHSA-534c-hcr7-67jg lists affected ranges: Packagist kimai/kimai >=0 <=2.20.1) Commands are suggestions: review each one before running it.
Loading voting…