Silverstripe uses TinyMCE which allows svg files linked in object tags
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/framework 5.2.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/framework
- Affected
- < 5.2.16
- Fixed in
- 5.2.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-52cw-pvq9-9m5v lists affected ranges: Packagist silverstripe/framework >=0 <5.2.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact TinyMCE v6 has a configuration value convertunsafeembeds set to false which allows svg files containing javascript to be used in <object or <embed tags, which can be used as a vector for XSS attacks. Note that <embed tags are not allowed by default. After patching the default value of convertunsafeembeds will be set to true. This means that <object tags will be converted to iframes instead the next time the page is saved, which may break any pages that rely upon previously saved <object tags. Developers can override this configuration if desired to revert to the original behaviour. We reviewed the potential impact of this vulnerability within the context of Silverstripe CMS. We concluded this is a medium impact vulnerability given how TinyMCE is used by Silverstripe CMS. References: - https://www.silverstripe.org/download/security-releases/ss-2024-001 - https://github.com/advisories/GHSA-5359-pvf2-pw78
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-52cw-pvq9-9m5v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-52cw-pvq9-9m5v Advisory: Silverstripe uses TinyMCE which allows svg files linked in object tags IDs: GHSA-52cw-pvq9-9m5v Record: https://patchnext.com/advisories/ghsa-52cw-pvq9-9m5v (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/framework 5.2.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/framework: affected < 5.2.16; fixed in 5.2.16 ## Suggested inspection (read-only) - Packagist silverstripe/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-52cw-pvq9-9m5v (GitHub-reviewed advisory GHSA-52cw-pvq9-9m5v lists affected ranges: Packagist silverstripe/framework >=0 <5.2.16) Commands are suggestions: review each one before running it.
Loading voting…