Skip to content

← Actionable
Medium, CVSS 5.9

Panic during unmarshal of Hello Verify Request in github.com/pion/dtls/v2

GHSA-4xgv-j62q-h3rj

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/pion/dtls/v2

    Affected
    < 2.2.4
    Fixed in
    2.2.4
  • Go github.com/pion/dtls

    Affected
    <= 1.5.4
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact During the unmarshalling of a hello verify request we could try to unmarshal into too small a buffer. is could result in a panic leading the program to crash. This issue could be abused to cause a denial of service. Workaround None, upgrade to 2.2.4

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4xgv-j62q-h3rj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-4xgv-j62q-h3rj

Advisory: Panic during unmarshal of Hello Verify Request in github.com/pion/dtls/v2
IDs: GHSA-4xgv-j62q-h3rj
Record: https://patchnext.com/advisories/ghsa-4xgv-j62q-h3rj (revision 1, source checked 26 Oct 2026, 14:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/pion/dtls/v2 2.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/pion/dtls/v2: affected < 2.2.4; fixed in 2.2.4
- Go github.com/pion/dtls: affected <= 1.5.4

## Suggested inspection (read-only)
- Go github.com/pion/dtls/v2: check the installed version with your package manager.
- Go github.com/pion/dtls: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/pion/dtls/v2, github.com/pion/dtls.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4xgv-j62q-h3rj (GitHub-reviewed advisory GHSA-4xgv-j62q-h3rj lists affected ranges: Go github.com/pion/dtls/v2 >=0 =0 <=1.5.4)

Commands are suggestions: review each one before running it.

Loading voting…