Skip to content

← Actionable
High, CVSS 7.8amended

Arbitrary code execution in ExifTool

GHSA-4whq-r978-2x68

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (exiftool-vendored 14.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Arbitrary code execution can occur when running exiftool against files with hostile metadata payloads. Patches ExifTool has already been patched in version 12.24. exiftool-vendored, which vendors ExifTool, includes this patch in v14.3.0. Workarounds No. References https://twitter.com/wcbowling/status/1385803927321415687 https://nvd.nist.gov/vuln/detail/CVE-2021-22204 For more information If you have any questions or comments about this advisory: Open an issue in exiftool-vendored

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4whq-r978-2x68

  2. Revision 1 · created ·

    Published from osv record GHSA-4whq-r978-2x68

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-4whq-r978-2x68

Advisory: Arbitrary code execution in ExifTool
IDs: GHSA-4whq-r978-2x68
Record: https://patchnext.com/advisories/ghsa-4whq-r978-2x68 (revision 2, source checked 26 Oct 2026, 12:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: exiftool-vendored 14.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm exiftool-vendored: affected < 14.3.0; fixed in 14.3.0

## Suggested inspection (read-only)
- `npm ls exiftool-vendored --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on exiftool-vendored.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4whq-r978-2x68 (OSV record GHSA-4whq-r978-2x68 lists affected ranges: npm exiftool-vendored >=0 <14.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-4whq-r978-2x68 (GitHub-reviewed advisory GHSA-4whq-r978-2x68 lists affected ranges: npm exiftool-vendored >=0 <14.3.0)

Commands are suggestions: review each one before running it.

Loading voting…