Skip to content

← Actionable
Medium, CVSS 6.9amended

Vyper: Call stack corruption when passing complex type containing non-base type members as argument

CVE-2020-37287GHSA-4v7v-gqf9-ww2g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vyper 0.2.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vyper

    Affected
    < 0.2.6
    Fixed in
    0.2.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-37287: 0.25% estimated exploitation activity in the next 30 days; percentile 16.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When we pass a multi-dimensional array (like [[1, 2], [3, 4]]) as an argument to internal/external functions we get incorrect output. This is due to a stack management issue, because it was assumed that the size of each subtype of an array/struct is 32, which is not always correct. Example code: Please see #2183 for further information Patches This problem was fixed in #2184, and released as a part of v0.2.6.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-4v7v-gqf9-ww2g

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-4v7v-gqf9-ww2g

  4. Revision 1 · created ·

    Published from ghsa record GHSA-4v7v-gqf9-ww2g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-37287

Advisory: Vyper: Call stack corruption when passing complex type containing non-base type members as argument
IDs: CVE-2020-37287, GHSA-4v7v-gqf9-ww2g
Record: https://patchnext.com/advisories/ghsa-4v7v-gqf9-ww2g (revision 4, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vyper 0.2.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vyper: affected < 0.2.6; fixed in 0.2.6

## Suggested inspection (read-only)
- `python -m pip show vyper`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vyper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4v7v-gqf9-ww2g (GitHub-reviewed advisory GHSA-4v7v-gqf9-ww2g lists affected ranges: PyPI vyper >=0 <0.2.6)
- Verified: https://osv.dev/vulnerability/GHSA-4v7v-gqf9-ww2g (OSV record GHSA-4v7v-gqf9-ww2g lists affected ranges: PyPI vyper >=0 <0.2.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…