Skip to content

← Actionable
Medium, CVSS 6.5amended

SurrealDB: Crafting malicious LIVE queries writes to the database, resulting in DoS, without permission to the table required

CVE-2026-63754GHSA-4v76-cw68-4vc9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb 3.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io surrealdb

    Affected
    < 3.1.0
    Fixed in
    3.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-63754: 0.45% estimated exploitation activity in the next 30 days; percentile 39.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A `LIVE` query whose `WHERE` clause evaluates to an error caused the source data modifier (the user creating, updating, or deleting a record on the watched table) to fail instead. Calling any arbitrary SurrealQL function with a typed parameter and passing a value of the wrong type — for example `LIVE SELECT * FROM t WHERE string::trim(deny)` — triggered an evaluation error inside the LIVE notification path. That error then propagated through to the triggering write, rolling back the attempted change. While such a `LIVE` query was registered, all `CREATE`, `UPDATE`, and `DELETE` operations on the watched table failed — including those issued by a root user — for as long as the registration remained active. Registering the `LIVE` required `select` permission on the table; no other permission on the table was needed.

Impact An authenticated user with `select` permission on a table can prevent all `CREATE`, `UPDATE`, and `DELETE` operations on that table — by any other user, up to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-4v76-cw68-4vc9

  2. Revision 1 · created ·

    Published from ghsa record GHSA-4v76-cw68-4vc9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63754

Advisory: SurrealDB: Crafting malicious LIVE queries writes to the database, resulting in DoS, without permission to the table required
IDs: CVE-2026-63754, GHSA-4v76-cw68-4vc9
Record: https://patchnext.com/advisories/ghsa-4v76-cw68-4vc9 (revision 2, source checked 4 Nov 2026, 06:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: surrealdb 3.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io surrealdb: affected < 3.1.0; fixed in 3.1.0

## Suggested inspection (read-only)
- crates.io surrealdb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on surrealdb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4v76-cw68-4vc9 (GitHub-reviewed advisory GHSA-4v76-cw68-4vc9 lists affected ranges: crates.io surrealdb >=0 <3.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-4v76-cw68-4vc9 (OSV record GHSA-4v76-cw68-4vc9 lists affected ranges: crates.io surrealdb >=0 <3.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…