Skip to content

← Actionable
High, CVSS 7.2

Prometheus vulnerable to basic authentication bypass

GHSA-4v48-4q5m-8vx4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/prometheus/prometheus 2.40.4, 2.37.4; github.com/prometheus/prometheus/v2 2.40.4, 2.37.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Prometheus can be secured by a web.yml file that specifies usernames and hashed passwords for basic authentication. Passwords are hashed with bcrypt, which means that even if you have access to the hash, it is very hard to find the original password back. However, a flaw in the way this mechanism was implemented in the exporter toolkit makes it possible with people who know the hashed password to authenticate against Prometheus. A request can be forged by an attacker to poison the internal cache used to cache the computation of hashes and make subsequent requests successful. This cache is used in both happy and unhappy scenarios in order to limit side channel attacks that could tell an attacker if a user is present in the file or not. Patches Prometheus 2.37.4 (LTS) and 2.40.4 have been released to address this issue. Workarounds There is no workaround but attacker must have access to the hashed password, stored in disk, to bypass the authentication. Credit We want to thank…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4v48-4q5m-8vx4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-4v48-4q5m-8vx4

Advisory: Prometheus vulnerable to basic authentication bypass
IDs: GHSA-4v48-4q5m-8vx4
Record: https://patchnext.com/advisories/ghsa-4v48-4q5m-8vx4 (revision 1, source checked 26 Oct 2026, 15:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/prometheus/prometheus 2.40.4, 2.37.4; github.com/prometheus/prometheus/v2 2.40.4, 2.37.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/prometheus/prometheus: affected >= 2.24.1, < 2.37.4; >= 2.38.0, < 2.40.4; fixed in 2.37.4, 2.40.4
- Go github.com/prometheus/prometheus/v2: affected >= 2.24.1, < 2.37.4; >= 2.38.0, < 2.40.4; fixed in 2.37.4, 2.40.4

## Suggested inspection (read-only)
- Go github.com/prometheus/prometheus: check the installed version with your package manager.
- Go github.com/prometheus/prometheus/v2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/prometheus/prometheus, github.com/prometheus/prometheus/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4v48-4q5m-8vx4 (GitHub-reviewed advisory GHSA-4v48-4q5m-8vx4 lists affected ranges: Go github.com/prometheus/prometheus >=2.24.1 =2.38.0 =2.24.1 =2.38.0 <2.40.4)

Commands are suggestions: review each one before running it.

Loading voting…