Skip to content

← Actionable
Unrated

tokio::io::ReadHalf ::unsplit is Unsound

GHSA-4q83-7cq4-p6wg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tokio 1.24.2, 1.20.4, 1.18.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io tokio

    Affected
    >= 1.21.0, < 1.24.2>= 1.19.0, < 1.20.4>= 0.2.0, < 1.18.5
    Fixed in
    1.20.4, 1.18.5, 1.24.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

tokio::io::ReadHalf<T::unsplit can violate the Pin contract The soundness issue is described in the tokio/issues#5372 Specific set of conditions needed to trigger an issue (a !Unpin type in ReadHalf) is unusual, combined with the difficulty of making any arbitrary use-after-free exploitable in Rust without doing a lot of careful alignment of data types in the surrounding code. The tokio feature io-util is also required to be enabled to trigger this soundness issue. Thanks to zachs18 reporting the issue to Tokio team responsibly and taiki-e and carllerche appropriately responding and fixing the soundness bug. Tokio before 0.2.0 used futures 0.1 that did not have Pin, so it is not affected by this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4q83-7cq4-p6wg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-4q83-7cq4-p6wg

Advisory: `tokio::io::ReadHalf ::unsplit` is Unsound
IDs: GHSA-4q83-7cq4-p6wg
Record: https://patchnext.com/advisories/ghsa-4q83-7cq4-p6wg (revision 1, source checked 26 Oct 2026, 15:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tokio 1.24.2, 1.20.4, 1.18.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io tokio: affected >= 1.21.0, < 1.24.2; >= 1.19.0, < 1.20.4; >= 0.2.0, < 1.18.5; fixed in 1.20.4, 1.18.5, 1.24.2

## Suggested inspection (read-only)
- crates.io tokio: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tokio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4q83-7cq4-p6wg (GitHub-reviewed advisory GHSA-4q83-7cq4-p6wg lists affected ranges: crates.io tokio >=1.21.0 =1.19.0 =0.2.0 <1.18.5)

Commands are suggestions: review each one before running it.

Loading voting…