Skip to content

← Actionable
Medium, CVSS 5.4

Silverstripe has Cross-site Scripting (XSS) vulnerabilities inherited from TinyMCE

GHSA-4q66-g4mm-8rg5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/admin 1.13.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

TinyMCE 4.x is vulnerable to several XSS vectors, which had been patched in later versions. Two of these have been identified as affecting silverstripe/admin. Only Silverstripe CMS 4 is affected by this issue. It's not possible to upgrade Silverstripe CMS 4 to use a more recent release of TinyMCE without introducing breaking changes. Instead, the security patches that shipped in later releases of TinyMCE have been backported to the TinyMCE version bundled in silverstripe/admin. Silverstripe CMS 5 is not affected by those vulnerabilities because it uses TinyMCE 6. You can find more information about the underlying vulnerabilities in those GitHub security advisories: - GHSA-5h9g-x5rv-25wg Cross-site scripting vulnerability in TinyMCE - GHSA-w7jx-j77m-wp65 Cross-site scripting vulnerability in TinyMCE

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4q66-g4mm-8rg5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-4q66-g4mm-8rg5

Advisory: Silverstripe has Cross-site Scripting (XSS) vulnerabilities inherited from TinyMCE
IDs: GHSA-4q66-g4mm-8rg5
Record: https://patchnext.com/advisories/ghsa-4q66-g4mm-8rg5 (revision 1, source checked 26 Oct 2026, 14:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/admin 1.13.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/admin: affected < 1.13.6; fixed in 1.13.6

## Suggested inspection (read-only)
- Packagist silverstripe/admin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/admin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4q66-g4mm-8rg5 (GitHub-reviewed advisory GHSA-4q66-g4mm-8rg5 lists affected ranges: Packagist silverstripe/admin >=0 <1.13.6)

Commands are suggestions: review each one before running it.

Loading voting…