TorchServe Pre-Auth Remote Code Execution
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (torchserve 0.8.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI torchserve
- Affected
- >= 0.3.0, < 0.8.2
- Fixed in
- 0.8.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4mqg-h5jf-j9m7 lists affected ranges: PyPI torchserve >=0.3.0 <0.8.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4mqg-h5jf-j9m7 lists affected ranges: PyPI torchserve >=0.3.0 <0.8.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Use of Open Source Library potentially exposed to RCE Issue: Use of a version of the SnakeYAML v1.31 open source library with multiple issues that potentially exposes the user to unsafe deserialization of Java objects. This could allow third parties to execute arbitrary code on the target system. This issue is present in versions 0.3.0 to 0.8.1. Mitigation: A pull request to address this issue has been merged - https://github.com/pytorch/serve/pull/2523. TorchServe release 0.8.2 includes this fix. Patches TorchServe release 0.8.2 includes fixes to address the previously listed issue: https://github.com/pytorch/serve/releases/tag/v0.8.2 Tags for upgraded DLC release User can use the following new image tags to pull DLCs that ship with patched TorchServe version 0.8.2: x86 GPU v1.9-pt-ec2-2.0.1-inf-gpu-py310 v1.8-pt-sagemaker-2.0.1-inf-gpu-py310 x86 CPU v1.8-pt-ec2-2.0.1-inf-cpu-py310 v1.7-pt-sagemaker-2.0.1-inf-cpu-py310 Graviton v1.7-pt-graviton-ec2-2.0.1-inf-cpu-py310…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4mqg-h5jf-j9m7
- Revision 1 · created ·
Published from osv record GHSA-4mqg-h5jf-j9m7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-4mqg-h5jf-j9m7 Advisory: TorchServe Pre-Auth Remote Code Execution IDs: GHSA-4mqg-h5jf-j9m7 Record: https://patchnext.com/advisories/ghsa-4mqg-h5jf-j9m7 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: torchserve 0.8.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI torchserve: affected >= 0.3.0, < 0.8.2; fixed in 0.8.2 ## Suggested inspection (read-only) - `python -m pip show torchserve`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on torchserve. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4mqg-h5jf-j9m7 (OSV record GHSA-4mqg-h5jf-j9m7 lists affected ranges: PyPI torchserve >=0.3.0 <0.8.2 (fixed)) - Verified: https://github.com/advisories/GHSA-4mqg-h5jf-j9m7 (GitHub-reviewed advisory GHSA-4mqg-h5jf-j9m7 lists affected ranges: PyPI torchserve >=0.3.0 <0.8.2) Commands are suggestions: review each one before running it.
Loading voting…