Skip to content

← Actionable
Low, CVSS 3.6amended

Arbitrary JavaScript execution due to using outdated libraries

GHSA-4m3g-6r7g-jv4f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gradio-pdf 0.0.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.6 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary gradio-pdf projects with dependencies on the pdf.js library are vulnerable to CVE-2024-4367, which allows arbitrary JavaScript execution. PoC 1. Generate a pdf file with a malicious script in the fontmatrix. (This will run alert(‘XSS’).) poc.pdf 2. Run the app. In this PoC, I've used the demo for a simple proof. 3. Upload a PDF file containing the script. 4. Check that the script is running. Impact Malicious scripts can be injected into the code, and when linked with vulnerabilities such as CSRF, it can cause even greater damage. In particular, It can become a source of further attacks, especially when linked to social engineering. Mitigation Upgrade the pdf.js to v4.2.67, which removes the vulnerability. (or set the option isEvalSupported to false.) Reference 1. https://codeanlabs.com/blog/research/cve-2024-4367-arbitrary-js-execution-in-pdf-js/ 2. https://github.com/mozilla/pdf.js/pull/18015

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4m3g-6r7g-jv4f

  2. Revision 1 · created ·

    Published from osv record GHSA-4m3g-6r7g-jv4f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-4m3g-6r7g-jv4f

Advisory: Arbitrary JavaScript execution due to using outdated libraries
IDs: GHSA-4m3g-6r7g-jv4f
Record: https://patchnext.com/advisories/ghsa-4m3g-6r7g-jv4f (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gradio-pdf 0.0.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gradio-pdf: affected < 0.0.10; fixed in 0.0.10

## Suggested inspection (read-only)
- `python -m pip show gradio-pdf`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gradio-pdf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4m3g-6r7g-jv4f (OSV record GHSA-4m3g-6r7g-jv4f lists affected ranges: PyPI gradio-pdf >=0 <0.0.10 (fixed))
- Verified: https://github.com/advisories/GHSA-4m3g-6r7g-jv4f (GitHub-reviewed advisory GHSA-4m3g-6r7g-jv4f lists affected ranges: PyPI gradio-pdf >=0 <0.0.10)

Commands are suggestions: review each one before running it.

Loading voting…