OpenClaw: Pairing-scoped device tokens could mint operator.admin and reach node RCE
CVE-2026-32922GHSA-4jpw-hj22-2xmc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.3.11
- Fixed in
- 2026.3.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4jpw-hj22-2xmc lists affected ranges: npm openclaw >=0 <2026.3.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4jpw-hj22-2xmc lists affected ranges: npm openclaw >=0 <2026.3.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-32922: 0.73% estimated exploitation activity in the next 30 days; percentile 54.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In affected versions of openclaw, a caller holding only operator.pairing could use device.token.rotate to mint a new token with broader scopes for an already paired device. If the target device was approved for operator.admin, the attacker could obtain an administrative token without already holding administrative scope. Impact This is a critical authorization flaw. On deployments with connected node hosts or companion apps that expose system.run, the escalated token could then modify node execution approvals and reach real remote code execution on the node. Even without nodes, the flaw still granted unauthorized gateway-admin access. Affected Packages and Versions - Package: openclaw (npm) - Affected versions: <= 2026.3.8 - Fixed in: 2026.3.11 Technical Details device.token.rotate accepted caller-supplied target scopes and validated them against the target device's approved scopes, but it did not constrain the newly minted scopes to the caller's own current scope set. That…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4jpw-hj22-2xmc
- Revision 2 · amended ·
Amended from osv record GHSA-4jpw-hj22-2xmc
- Revision 1 · created ·
Published from ghsa record GHSA-4jpw-hj22-2xmc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32922 Advisory: OpenClaw: Pairing-scoped device tokens could mint `operator.admin` and reach node RCE IDs: CVE-2026-32922, GHSA-4jpw-hj22-2xmc Record: https://patchnext.com/advisories/ghsa-4jpw-hj22-2xmc (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.11. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.3.11; fixed in 2026.3.11 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4jpw-hj22-2xmc (GitHub-reviewed advisory GHSA-4jpw-hj22-2xmc lists affected ranges: npm openclaw >=0 <2026.3.11) - Verified: https://osv.dev/vulnerability/GHSA-4jpw-hj22-2xmc (OSV record GHSA-4jpw-hj22-2xmc lists affected ranges: npm openclaw >=0 <2026.3.11 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…