Skip to content

← Actionable
High, CVSS 8.7

Finality Provider vulnerable to anti-slashing bypassing due to misconfiguration

GHSA-4jmp-x7mh-rgmr

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-4jmp-x7mh-rgmr lists affected ranges: Go github.com/babylonlabs-io/finality-provider >=0 =1.1.0-rc.0 =1.1.0-rc.1 =1.99.0-devnet.6 <=1.99.0-devnet.6

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The anti-slashing is not effective if the attacker can access EOTS manager endpoints. Impact If the EOTS manager endpoints are open to public without HMAC protection, the attacker can manually cause slashing of the finality provider through the RPC endpoints. Report credits go to: x.com/RebelsRunways

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4jmp-x7mh-rgmr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-4jmp-x7mh-rgmr

Advisory: Finality Provider vulnerable to anti-slashing bypassing due to misconfiguration
IDs: GHSA-4jmp-x7mh-rgmr
Record: https://patchnext.com/advisories/ghsa-4jmp-x7mh-rgmr (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/babylonlabs-io/finality-provider 1.0.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/babylonlabs-io/finality-provider: affected <= 1.0.3; >= 1.1.0-rc.0, <= 1.1.0-rc.0; >= 1.1.0-rc.1, <= 1.1.0-rc.1; >= 1.99.0-devnet.6, <= 1.99.0-devnet.6; fixed in 1.0.4

## Suggested inspection (read-only)
- Go github.com/babylonlabs-io/finality-provider: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/babylonlabs-io/finality-provider.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4jmp-x7mh-rgmr (GitHub-reviewed advisory GHSA-4jmp-x7mh-rgmr lists affected ranges: Go github.com/babylonlabs-io/finality-provider >=0 =1.1.0-rc.0 =1.1.0-rc.1 =1.99.0-devnet.6 <=1.99.0-devnet.6)

Commands are suggestions: review each one before running it.

Loading voting…