Default Express middleware security check is ignored in production
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@cubejs-backend/api-gateway 0.11.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @cubejs-backend/api-gateway
- Affected
- >= 0.11.0, <= 0.11.16
- Fixed in
- 0.11.17
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4j6x-w426-6rc6 lists affected ranges: npm @cubejs-backend/api-gateway >=0.11.0 <0.11.17 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4j6x-w426-6rc6 lists affected ranges: npm @cubejs-backend/api-gateway >=0.11.0 <=0.11.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Default Express middleware security check is ignored in production Impact All Cube.js deployments that use affected versions of @cubejs-backend/api-gateway with default express authentication middleware in production environment are affected. Patches @cubejs-backend/api-gateway@0.11.17 Workarounds Override default authentication express middleware: https://cube.dev/docs/@cubejs-backend-server-core#options-reference-check-auth-middleware For more information If you have any questions or comments about this advisory: Open an issue in https://github.com/cube-js/cube.js/issues Reach out us in community Slack: https://slack.cube.dev/
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4j6x-w426-6rc6
- Revision 1 · created ·
Published from osv record GHSA-4j6x-w426-6rc6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-4j6x-w426-6rc6 Advisory: Default Express middleware security check is ignored in production IDs: GHSA-4j6x-w426-6rc6 Record: https://patchnext.com/advisories/ghsa-4j6x-w426-6rc6 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @cubejs-backend/api-gateway 0.11.17. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @cubejs-backend/api-gateway: affected >= 0.11.0, <= 0.11.16; fixed in 0.11.17 ## Suggested inspection (read-only) - `npm ls @cubejs-backend/api-gateway --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @cubejs-backend/api-gateway. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4j6x-w426-6rc6 (OSV record GHSA-4j6x-w426-6rc6 lists affected ranges: npm @cubejs-backend/api-gateway >=0.11.0 <0.11.17 (fixed)) - Verified: https://github.com/advisories/GHSA-4j6x-w426-6rc6 (GitHub-reviewed advisory GHSA-4j6x-w426-6rc6 lists affected ranges: npm @cubejs-backend/api-gateway >=0.11.0 <=0.11.16) Commands are suggestions: review each one before running it.
Loading voting…