A single post-release of dydx-v4-client contained obfuscated multi-stage loader
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dydx-v4-client 1.1.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI dydx-v4-client
- Affected
- >= 1.1.5.post1, <= 1.1.5.post1
- Fixed in
- 1.1.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4f84-67cv-qrv3 lists affected ranges: PyPI dydx-v4-client >=1.1.5.post1 <1.1.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4f84-67cv-qrv3 lists affected ranges: PyPI dydx-v4-client >=1.1.5.post1 <=1.1.5.post1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
A PyPI user account compromised by an attacker and was able to upload a malicious version (1.1.5.post1) of the dydx-v4-client package. This version contains a highly obfuscated multi-stage loader that ultimately executes malicious code on the host system. While the final payload is not visible because it is tucked away inside 100 layers of encoding, the structural design—specifically the use of recursive decompression followed by an exec() call is a definitive indicator of malicious software, likely a "Crypter" or "Dropper" masquerading as a cryptocurrency-related utility with the intent on connecting to hxxps://dydx[.]priceoracle[.]site/py to download and execute further payloads. Users of the dydx-v4-client package should immediately uninstall version 1.1.5.post1and revert to the last known good version (1.1.5) or later secure versions once available. Additionally, users should monitor their systems for any unusual activity and consider running security scans to detect any…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4f84-67cv-qrv3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4f84-67cv-qrv3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-4f84-67cv-qrv3 Advisory: A single post-release of dydx-v4-client contained obfuscated multi-stage loader IDs: GHSA-4f84-67cv-qrv3 Record: https://patchnext.com/advisories/ghsa-4f84-67cv-qrv3 (revision 3, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dydx-v4-client 1.1.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI dydx-v4-client: affected >= 1.1.5.post1, <= 1.1.5.post1; fixed in 1.1.5 ## Suggested inspection (read-only) - `python -m pip show dydx-v4-client`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dydx-v4-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4f84-67cv-qrv3 (OSV record GHSA-4f84-67cv-qrv3 lists affected ranges: PyPI dydx-v4-client >=1.1.5.post1 <1.1.5 (fixed)) - Verified: https://github.com/advisories/GHSA-4f84-67cv-qrv3 (GitHub-reviewed advisory GHSA-4f84-67cv-qrv3 lists affected ranges: PyPI dydx-v4-client >=1.1.5.post1 <=1.1.5.post1) Commands are suggestions: review each one before running it.
Loading voting…