flagd: Multiple Go Runtime CVEs Impact Security and Availability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/open-feature/flagd/flagd-proxy 0.8.2; github.com/open-feature/flagd/flagd 0.13.1; github.com/open-feature/flagd/core 0.13.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/open-feature/flagd/flagd-proxy
- Affected
- < 0.8.2
- Fixed in
- 0.8.2
Go github.com/open-feature/flagd/flagd
- Affected
- < 0.13.1
- Fixed in
- 0.13.1
Go github.com/open-feature/flagd/core
- Affected
- < 0.13.1
- Fixed in
- 0.13.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4c5f-9mj4-m247 lists affected ranges: Go github.com/open-feature/flagd/core >=0 =0 =0 <0.13.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary In 2025, several vulnerabilities in the Go Standard Library were disclosed, impacting Go-based applications like flagd (the evaluation engine for OpenFeature). These CVEs primarily focus on Denial of Service (DoS) through resource exhaustion and Race Conditions in database handling. | CVE ID | Impacted Package | Severity | Description & Impact on flagd | | -- | -- | -- | -- | | CVE-2025-47907 | database/sql | 7.0 (High) | Race Condition: Canceling a query during a Scan call can return data from the wrong query. Critical if flagd uses SQL-based sync providers (e.g., Postgres), potentially leading to incorrect flag configurations. | | CVE-2025-61725 | net/mail | 7.5 (High) | DoS: Inefficient complexity in ParseAddress. Attackers can provide crafted email strings with large domain literals to exhaust CPU if flagd parses email-formatted metadata. | | CVE-2025-61723 | encoding/pem | 7.5 (High) | DoS: Quadratic complexity when parsing invalid PEM inputs. Relevant if flagd loads TLS…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4c5f-9mj4-m247
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-4c5f-9mj4-m247 Advisory: flagd: Multiple Go Runtime CVEs Impact Security and Availability IDs: GHSA-4c5f-9mj4-m247 Record: https://patchnext.com/advisories/ghsa-4c5f-9mj4-m247 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/open-feature/flagd/flagd-proxy 0.8.2; github.com/open-feature/flagd/flagd 0.13.1; github.com/open-feature/flagd/core 0.13.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/open-feature/flagd/flagd-proxy: affected < 0.8.2; fixed in 0.8.2 - Go github.com/open-feature/flagd/flagd: affected < 0.13.1; fixed in 0.13.1 - Go github.com/open-feature/flagd/core: affected < 0.13.1; fixed in 0.13.1 ## Suggested inspection (read-only) - Go github.com/open-feature/flagd/flagd-proxy: check the installed version with your package manager. - Go github.com/open-feature/flagd/flagd: check the installed version with your package manager. - Go github.com/open-feature/flagd/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/open-feature/flagd/flagd-proxy, github.com/open-feature/flagd/flagd, github.com/open-feature/flagd/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4c5f-9mj4-m247 (GitHub-reviewed advisory GHSA-4c5f-9mj4-m247 lists affected ranges: Go github.com/open-feature/flagd/core >=0 =0 =0 <0.13.1) Commands are suggestions: review each one before running it.
Loading voting…