CefSharp affected by libvpx's heap buffer overflow in vp8 encoding
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cefsharp.common.netcore 117.2.20; cefsharp.common 117.2.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet cefsharp.common.netcore
- Affected
- < 117.2.20
- Fixed in
- 117.2.20
NuGet cefsharp.common
- Affected
- < 117.2.20
- Fixed in
- 117.2.20
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4c29-gfrp-g6x9 lists affected ranges: NuGet cefsharp.common >=0 =0 <117.2.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Google is aware that an exploit for CVE-2023-5217 exists in the wild. Description Heap buffer overflow in vp8 encoding in libvpx in Google Chrome prior to 117.0.5938.132 and libvpx 1.13.1 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High) References - https://www.cve.org/CVERecord?id=CVE-2023-5217 - https://nvd.nist.gov/vuln/detail/CVE-2023-5217
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4c29-gfrp-g6x9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-4c29-gfrp-g6x9 Advisory: CefSharp affected by libvpx's heap buffer overflow in vp8 encoding IDs: GHSA-4c29-gfrp-g6x9 Record: https://patchnext.com/advisories/ghsa-4c29-gfrp-g6x9 (revision 1, source checked 26 Oct 2026, 16:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cefsharp.common.netcore 117.2.20; cefsharp.common 117.2.20. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet cefsharp.common.netcore: affected < 117.2.20; fixed in 117.2.20 - NuGet cefsharp.common: affected < 117.2.20; fixed in 117.2.20 ## Suggested inspection (read-only) - NuGet cefsharp.common.netcore: check the installed version with your package manager. - NuGet cefsharp.common: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cefsharp.common.netcore, cefsharp.common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4c29-gfrp-g6x9 (GitHub-reviewed advisory GHSA-4c29-gfrp-g6x9 lists affected ranges: NuGet cefsharp.common >=0 =0 <117.2.20) Commands are suggestions: review each one before running it.
Loading voting…