Skip to content

← Actionable
High, CVSS 7.7

ArcadeDB: Privilege escalation via reader role in /api/v1/command JS scripting language — arbitrary host file read

GHSA-48qw-824m-86pr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.arcadedb:arcadedb-server 26.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact A user holding only reader (read-only) privileges on a single database could execute arbitrary JVM code by sending a "language": "js" command to the POST /api/v1/command/{database} HTTP endpoint, and use it to read arbitrary files on the host filesystem (e.g. /etc/passwd, configuration files), outside the scope of the database itself. Two cooperating defects made this possible: 1. Missing authorization on the scripting path (CWE-863 / CWE-269). Polyglot script execution (js and other GraalVM languages) never went through the database authorization checks applied to SQL/Cypher, so any authenticated principal - regardless of database role - could run scripts. 2. Sandbox whitelist bypass. The GraalVM sandbox restricts direct class lookups to a configured allowedPackages list, but a script could reach arbitrary classes by reflecting off the bound database object: database.getClass().getClassLoader().loadClass("java.io.File"). Process creation was already blocked…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-48qw-824m-86pr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-48qw-824m-86pr

Advisory: ArcadeDB: Privilege escalation via reader role in /api/v1/command JS scripting language — arbitrary host file read
IDs: GHSA-48qw-824m-86pr
Record: https://patchnext.com/advisories/ghsa-48qw-824m-86pr (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.arcadedb:arcadedb-server 26.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.arcadedb:arcadedb-server: affected < 26.7.1; fixed in 26.7.1

## Suggested inspection (read-only)
- Maven com.arcadedb:arcadedb-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.arcadedb:arcadedb-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-48qw-824m-86pr (GitHub-reviewed advisory GHSA-48qw-824m-86pr lists affected ranges: Maven com.arcadedb:arcadedb-server >=0 <26.7.1)

Commands are suggestions: review each one before running it.

Loading voting…