Insufficient covariance check makes self_cell unsound
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (self_cell 1.0.2, 0.10.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io self_cell
- Affected
- < 0.10.3>= 1.0.0, < 1.0.2
- Fixed in
- 1.0.2, 0.10.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-48m6-wm5p-rr6h lists affected ranges: crates.io self_cell >=0 =1.0.0 <1.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
All public versions prior to 1.02 used an insufficient check to ensure that users correctly marked the dependent type as either covariant or notcovariant. This allowed users to mark a dependent as covariant even though its type was not covariant but invariant, for certain invariant types involving trait object lifetimes. One example for such a dependent type is type Dependent<'a = RefCell<Box<dyn fmt::Display + 'a. Such a type allowed unsound usage in purely safe user code that leads to undefined behavior. The patched versions now produce a compile time error if such a type is marked as covariant.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-48m6-wm5p-rr6h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-48m6-wm5p-rr6h Advisory: Insufficient covariance check makes self_cell unsound IDs: GHSA-48m6-wm5p-rr6h Record: https://patchnext.com/advisories/ghsa-48m6-wm5p-rr6h (revision 1, source checked 26 Oct 2026, 15:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: self_cell 1.0.2, 0.10.3. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io self_cell: affected < 0.10.3; >= 1.0.0, < 1.0.2; fixed in 1.0.2, 0.10.3 ## Suggested inspection (read-only) - crates.io self_cell: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on self_cell. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-48m6-wm5p-rr6h (GitHub-reviewed advisory GHSA-48m6-wm5p-rr6h lists affected ranges: crates.io self_cell >=0 =1.0.0 <1.0.2) Commands are suggestions: review each one before running it.
Loading voting…