Skip to content

← Actionable
High, CVSS 7.2

PyO3 has type confusion when accessing data from sublasses of subclasses of native types with abi3 feature

GHSA-47qc-857f-7w7f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyo3 0.28.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io pyo3

    Affected
    >= 0.28.0, < 0.28.2
    Fixed in
    0.28.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

PyO3 0.28.1 added support for #[pyclass(extends=PyList)] struct NativeSub (and other native types) when targeting Python 3.12 and up with the abi3 feature. It was discovered that subclasses of such classes would use the type of the subclass when attempting to access to data of NativeSub contained within Python objects, amounting to memory corruption. PyO3 0.28.2 fixed the issue by using the type of (e.g.) NativeSub correctly.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-47qc-857f-7w7f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-47qc-857f-7w7f

Advisory: PyO3 has type confusion when accessing data from sublasses of subclasses of native types with `abi3` feature
IDs: GHSA-47qc-857f-7w7f
Record: https://patchnext.com/advisories/ghsa-47qc-857f-7w7f (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyo3 0.28.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io pyo3: affected >= 0.28.0, < 0.28.2; fixed in 0.28.2

## Suggested inspection (read-only)
- crates.io pyo3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyo3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-47qc-857f-7w7f (GitHub-reviewed advisory GHSA-47qc-857f-7w7f lists affected ranges: crates.io pyo3 >=0.28.0 <0.28.2)

Commands are suggestions: review each one before running it.

Loading voting…