Skip to content

← Actionable
High, CVSS 7.5

Improperly checked metadata on tools/armour itemstacks received from the client

GHSA-46c5-pfj8-fv65

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pocketmine/pocketmine-mp 4.2.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Due to a workaround applied in 1.13, an attacker may send a negative damage/meta value in a tool or armour item's NBT, which TypeConverter then blindly uses as if it was valid without being checked. When this invalid metadata value reaches Durable-setDamage(), an exception is thrown because the metadata is not within the expected range for damage values. This can be reproduced with either a too-large damage value, or a negative one. Patches c8e1cfcbee4945fd4b63d2a7e96025c59744d4f1 Workarounds In theory this can be checked by plugins using a custom TypeConverter, but this is likely to be very cumbersome. For more information Email us at team@pmmp.io

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-46c5-pfj8-fv65

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-46c5-pfj8-fv65

Advisory: Improperly checked metadata on tools/armour itemstacks received from the client
IDs: GHSA-46c5-pfj8-fv65
Record: https://patchnext.com/advisories/ghsa-46c5-pfj8-fv65 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pocketmine/pocketmine-mp 4.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pocketmine/pocketmine-mp: affected < 4.2.4; fixed in 4.2.4

## Suggested inspection (read-only)
- Packagist pocketmine/pocketmine-mp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pocketmine/pocketmine-mp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-46c5-pfj8-fv65 (GitHub-reviewed advisory GHSA-46c5-pfj8-fv65 lists affected ranges: Packagist pocketmine/pocketmine-mp >=0 <4.2.4)

Commands are suggestions: review each one before running it.

Loading voting…