Skip to content

← Actionable
Medium, CVSS 5.4amended

Trigger.dev: Cross-environment deployment cancel

CVE-2026-114079GHSA-4672-hwv6-gq62

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (trigger.dev 4.5.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
EPSS
  • CVE-2026-114079: 0.30% estimated exploitation activity in the next 30 days; percentile 23.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Trigger.dev isolates each project into multiple environments (dev, staging, prod, and per-PR preview branches), each with its own secret API key — the environment is a trust boundary (a dev/preview/CI key is lower-trust than a prod key). Most API routes enforce this by scoping resource lookups to the authenticated key's environment (where: { friendlyId, runtimeEnvironmentId: auth.environment.id }). The deployment cancel path does not. DeploymentService.getDeployment() scopes the lookup by projectId only — never environmentId — so a secret key for any environment in a project can cancel a deployment belonging to any other environment of the same project, including production. The deployment GET route, by contrast, is env-scoped — so the same key that is 404'd when trying to read a prod deployment can nonetheless cancel it. That asymmetry is the bug. Affected apps/webapp, HEAD 5d99457 (current main). Affects self-hosted and cloud. Root cause…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4672-hwv6-gq62

  2. Revision 2 · amended ·

    Amended from osv record GHSA-4672-hwv6-gq62

  3. Revision 1 · created ·

    Published from ghsa record GHSA-4672-hwv6-gq62

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114079

Advisory: Trigger.dev: Cross-environment deployment cancel
IDs: CVE-2026-114079, GHSA-4672-hwv6-gq62
Record: https://patchnext.com/advisories/ghsa-4672-hwv6-gq62 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: trigger.dev 4.5.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm trigger.dev: affected <= 4.5.5; fixed in 4.5.6

## Suggested inspection (read-only)
- `npm ls trigger.dev --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on trigger.dev.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4672-hwv6-gq62 (GitHub-reviewed advisory GHSA-4672-hwv6-gq62 lists affected ranges: npm trigger.dev >=0 <=4.5.5)
- Verified: https://osv.dev/vulnerability/GHSA-4672-hwv6-gq62 (OSV record GHSA-4672-hwv6-gq62 lists affected ranges: npm trigger.dev >=0 <4.5.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…