Skip to content

← Actionable
High, CVSS 7.5

TYPO3 CMS Privilege Escalation and SQL Injection

GHSA-45wj-jv2h-jwrf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 9.3.2, 8.7.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist typo3/cms-core

    Affected
    >= 8.5.0, < 8.7.17>= 9.0.0, < 9.3.2
    Fixed in
    9.3.2, 8.7.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Failing to properly dissociate system related configuration from user generated configuration, the Form Framework (system extension "form") is vulnerable to SQL injection and Privilege Escalation. Basically instructions can be persisted to a form definition file that were not configured to be modified - this applies to definitions managed using the form editor module as well as direct file upload using the regular file list module. A valid backend user account as well as having system extension form activated are needed in order to exploit this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-45wj-jv2h-jwrf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-45wj-jv2h-jwrf

Advisory: TYPO3 CMS Privilege Escalation and SQL Injection
IDs: GHSA-45wj-jv2h-jwrf
Record: https://patchnext.com/advisories/ghsa-45wj-jv2h-jwrf (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 9.3.2, 8.7.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms-core: affected >= 8.5.0, < 8.7.17; >= 9.0.0, < 9.3.2; fixed in 9.3.2, 8.7.17

## Suggested inspection (read-only)
- Packagist typo3/cms-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-45wj-jv2h-jwrf (GitHub-reviewed advisory GHSA-45wj-jv2h-jwrf lists affected ranges: Packagist typo3/cms-core >=8.5.0 =9.0.0 <9.3.2)

Commands are suggestions: review each one before running it.

Loading voting…