Skip to content

← Actionable
High, CVSS 7.8amended

code-ollama: grep_search Command Injection via Unescaped $() Shell Substitution (CWE-78)

GHSA-456v-xq2p-r4cj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (code-ollama 0.36.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

grepsearch Command Injection via Unescaped $() Shell Substitution (CWE-78) Summary The grepsearch tool in code-ollama constructs a shell command string by interpolating attacker-controlled pattern and path arguments, then executes it via childprocess.exec(). The sanitization only escapes backslashes and double-quote characters, leaving $() command substitution and backtick expansion fully intact. A malicious or compromised Ollama server can therefore inject and execute arbitrary OS commands with the privileges of the local user running code-ollama. Because grepsearch is classified as a read-only tool, it auto-executes in Plan mode without any user approval prompt, making this a no-interaction-required exploitation path. Severity is High (CVSS 7.8). Details Vulnerable sink — src/utils/tools/filesystem/grep.ts:58-66 Only \ and " are neutralized. The shell metacharacter sequence $() (and backtick-style substitution) is passed through unmodified. The resulting string is passed to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-456v-xq2p-r4cj

  2. Revision 2 · amended ·

    Amended from osv record GHSA-456v-xq2p-r4cj

  3. Revision 1 · created ·

    Published from ghsa record GHSA-456v-xq2p-r4cj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-456v-xq2p-r4cj

Advisory: code-ollama: `grep_search` Command Injection via Unescaped `$()` Shell Substitution (CWE-78)
IDs: GHSA-456v-xq2p-r4cj
Record: https://patchnext.com/advisories/ghsa-456v-xq2p-r4cj (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: code-ollama 0.36.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm code-ollama: affected <= 0.36.0; fixed in 0.36.1

## Suggested inspection (read-only)
- `npm ls code-ollama --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on code-ollama.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-456v-xq2p-r4cj (GitHub-reviewed advisory GHSA-456v-xq2p-r4cj lists affected ranges: npm code-ollama >=0 <=0.36.0)
- Verified: https://osv.dev/vulnerability/GHSA-456v-xq2p-r4cj (OSV record GHSA-456v-xq2p-r4cj lists affected ranges: npm code-ollama >=0 <0.36.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…