Laravel Guard bypass in Eloquent models
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist laravel/framework
- Affected
- >= 5.5.0, <= 5.5.49>= 6.0.0, < 6.18.34>= 7.0.0, < 7.23.2
- Fixed in
- 6.18.34, 7.23.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-44pg-c29v-hp6r lists affected ranges: Packagist laravel/framework >=5.5.0 =6.0.0 =7.0.0 <7.23.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
In laravel releases before 6.18.34 and 7.23.2. It was possible to mass assign Eloquent attributes that included the model's table name: When doing so, Eloquent would remove the table name from the attribute for you. This was a "convenience" feature of Eloquent and was not documented. However, when paired with validation, this can lead to unexpected and unvalidated values being saved to the database. For this reason, we have removed the automatic stripping of table names from mass-asignment operations so that the attributes go through the typical "fillable" / "guarded" logic. Any attributes containing table names that are not explicitly declared as fillable will be discarded. This security release will be a breaking change for applications that were relying on the undocumented table name stripping during mass assignment. Since this feature was relatively unknown and undocumented, we expect the vast majority of Laravel applications to be able to upgrade without issues.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-44pg-c29v-hp6r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-44pg-c29v-hp6r Advisory: Laravel Guard bypass in Eloquent models IDs: GHSA-44pg-c29v-hp6r Record: https://patchnext.com/advisories/ghsa-44pg-c29v-hp6r (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: laravel/framework 7.23.2, 6.18.34. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist laravel/framework: affected >= 5.5.0, <= 5.5.49; >= 6.0.0, < 6.18.34; >= 7.0.0, < 7.23.2; fixed in 6.18.34, 7.23.2 ## Suggested inspection (read-only) - Packagist laravel/framework: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on laravel/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-44pg-c29v-hp6r (GitHub-reviewed advisory GHSA-44pg-c29v-hp6r lists affected ranges: Packagist laravel/framework >=5.5.0 =6.0.0 =7.0.0 <7.23.2) Commands are suggestions: review each one before running it.
Loading voting…