Skip to content

← Actionable
Medium, CVSS 6.1

TYPO3 Cross-Site Scripting in Form Framework

GHSA-4459-qrcc-vfcf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 9.5.4, 8.7.23), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist typo3/cms-core

    Affected
    >= 8.5.0, < 8.7.23>= 9.0.0, < 9.5.4
    Fixed in
    8.7.23, 9.5.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Failing to properly encode user input, frontend forms handled by the form framework (system extension “form”) are vulnerable to cross-site scripting.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4459-qrcc-vfcf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-4459-qrcc-vfcf

Advisory: TYPO3 Cross-Site Scripting in Form Framework
IDs: GHSA-4459-qrcc-vfcf
Record: https://patchnext.com/advisories/ghsa-4459-qrcc-vfcf (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 9.5.4, 8.7.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms-core: affected >= 8.5.0, < 8.7.23; >= 9.0.0, < 9.5.4; fixed in 8.7.23, 9.5.4

## Suggested inspection (read-only)
- Packagist typo3/cms-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4459-qrcc-vfcf (GitHub-reviewed advisory GHSA-4459-qrcc-vfcf lists affected ranges: Packagist typo3/cms-core >=8.5.0 =9.0.0 <9.5.4)

Commands are suggestions: review each one before running it.

Loading voting…