Skip to content

← Actionable
Low, CVSS 3.7amended

Handlebars.js has a Property Access Validation Bypass in container.lookup

GHSA-442j-39wm-28r2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (handlebars 4.7.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm handlebars

    Affected
    >= 4.0.0, <= 4.7.8
    Fixed in
    4.7.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary In lib/handlebars/runtime.js, the container.lookup() function uses container.lookupProperty() as a gate check to enforce prototype-access controls, but then discards the validated result and performs a second, unguarded property access (depths[i][name]). This Time-of-Check Time-of-Use (TOCTOU) pattern means the security check and the actual read are decoupled, and the raw access bypasses any sanitization that lookupProperty may perform. Only relevant when the compat compile option is enabled ({compat: true}), which activates depthedLookup in lib/handlebars/compiler/javascript-compiler.js. Description The vulnerable code in lib/handlebars/runtime.js (lines 137–144): container.lookupProperty() (lines 119–136) enforces hasOwnProperty checks and resultIsAllowed() prototype-access controls. However, container.lookup() only uses lookupProperty as a boolean gate — if the gate passes (result != null), it then performs an independent, raw depths[i][name] access that circumvents any…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-442j-39wm-28r2

  2. Revision 1 · created ·

    Published from osv record GHSA-442j-39wm-28r2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-442j-39wm-28r2

Advisory: Handlebars.js has a Property Access Validation Bypass in container.lookup
IDs: GHSA-442j-39wm-28r2
Record: https://patchnext.com/advisories/ghsa-442j-39wm-28r2 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: handlebars 4.7.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm handlebars: affected >= 4.0.0, <= 4.7.8; fixed in 4.7.9

## Suggested inspection (read-only)
- `npm ls handlebars --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on handlebars.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-442j-39wm-28r2 (OSV record GHSA-442j-39wm-28r2 lists affected ranges: npm handlebars >=4.0.0 <4.7.9 (fixed))
- Verified: https://github.com/advisories/GHSA-442j-39wm-28r2 (GitHub-reviewed advisory GHSA-442j-39wm-28r2 lists affected ranges: npm handlebars >=4.0.0 <=4.7.8)

Commands are suggestions: review each one before running it.

Loading voting…