Skip to content

← Actionable
High, CVSS 8.7

Anchor: InterfaceAccount allows account substitution between unexpected types

GHSA-429q-fhh4-r6hj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (anchor-lang 1.0.0-rc.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io anchor-lang

    Affected
    >= 1.0.0-rc.1, <= 1.0.0-rc.1
    Fixed in
    1.0.0-rc.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Any uses of InterfaceAccount allows another unexpected account type to be passed, after https://github.com/solana-foundation/anchor/pull/3837 disabled discriminator checking for this type. The bug was originally reported and fixed in https://github.com/solana-foundation/anchor/pull/4139, see that PR for more details. Patches https://github.com/solana-foundation/anchor/pull/4139 patched the issue and was released in 1.0.0-rc.2. Users should upgrade to the latest released version of Anchor 1.0. References Bug landed in: https://github.com/solana-foundation/anchor/pull/3837 Bug fixed in: https://github.com/solana-foundation/anchor/pull/4139

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-429q-fhh4-r6hj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-429q-fhh4-r6hj

Advisory: Anchor: `InterfaceAccount` allows account substitution between unexpected types
IDs: GHSA-429q-fhh4-r6hj
Record: https://patchnext.com/advisories/ghsa-429q-fhh4-r6hj (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: anchor-lang 1.0.0-rc.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io anchor-lang: affected >= 1.0.0-rc.1, <= 1.0.0-rc.1; fixed in 1.0.0-rc.2

## Suggested inspection (read-only)
- crates.io anchor-lang: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on anchor-lang.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-429q-fhh4-r6hj (GitHub-reviewed advisory GHSA-429q-fhh4-r6hj lists affected ranges: crates.io anchor-lang >=1.0.0-rc.1 <=1.0.0-rc.1)

Commands are suggestions: review each one before running it.

Loading voting…