Skip to content

← Actionable
Medium, CVSS 5.9

GeoIP processor disables SSL certificate validation when downloading databases

GHSA-3xgr-h5hq-7299

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opensearch.dataprepper.plugins:geoip-processor 2.12.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact The GeoIP processor in Data Prepper was configured to trust all SSL certificates and disable hostname verification when downloading GeoIP databases from HTTP URLs, making downloads vulnerable to man-in-the-middle attacks. The GeoIP processor included a custom SSL implementation that completely bypassed certificate validation when downloading GeoIP databases from external sources. The initiateSSL() method incorrectly implemented an approach for trusting all certificates. Specifically it: Accepted all SSL certificates without validation Disabled server certificate verification Disabled client certificate verification Disabled hostname verification This configuration made database downloads vulnerable to man-in-the-middle attacks, potentially allowing attackers to serve malicious GeoIP databases that could compromise the integrity of geolocation data processing. Patches Data Prepper 2.12.2 contains a fix for this issue. Workarounds If upgrading is not immediately possible: Use…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3xgr-h5hq-7299

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-3xgr-h5hq-7299

Advisory: GeoIP processor disables SSL certificate validation when downloading databases
IDs: GHSA-3xgr-h5hq-7299
Record: https://patchnext.com/advisories/ghsa-3xgr-h5hq-7299 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.opensearch.dataprepper.plugins:geoip-processor 2.12.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.opensearch.dataprepper.plugins:geoip-processor: affected >= 2.7.0, < 2.12.2; fixed in 2.12.2

## Suggested inspection (read-only)
- Maven org.opensearch.dataprepper.plugins:geoip-processor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.opensearch.dataprepper.plugins:geoip-processor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3xgr-h5hq-7299 (GitHub-reviewed advisory GHSA-3xgr-h5hq-7299 lists affected ranges: Maven org.opensearch.dataprepper.plugins:geoip-processor >=2.7.0 <2.12.2)

Commands are suggestions: review each one before running it.

Loading voting…