Skip to content

← Actionable
Low, CVSS 3.5amended

Sensitive Data Exposure in sequelize-cli

GHSA-3xc7-xg67-pw99

What to do

Vendor response not established. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm sequelize-cli

    Affected
    <= 5.4.0
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Versions of sequelize-cli prior to 5.5.0 are vulnerable to Sensitive Data Exposure. The function filteredURL() does not properly sanitize the config.password value which may cause passwords with special characters to be logged in plain text. Recommendation Upgrade to version 5.5.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3xc7-xg67-pw99

  2. Revision 1 · created ·

    Published from osv record GHSA-3xc7-xg67-pw99

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-3xc7-xg67-pw99

Advisory: Sensitive Data Exposure in sequelize-cli
IDs: GHSA-3xc7-xg67-pw99
Record: https://patchnext.com/advisories/ghsa-3xc7-xg67-pw99 (revision 2, source checked 26 Oct 2026, 12:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor response not established. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sequelize-cli: affected <= 5.4.0

## Suggested inspection (read-only)
- `npm ls sequelize-cli --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sequelize-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3xc7-xg67-pw99 (OSV record GHSA-3xc7-xg67-pw99 lists affected ranges: npm sequelize-cli >=0 <=5.4.0)
- Verified: https://github.com/advisories/GHSA-3xc7-xg67-pw99 (GitHub-reviewed advisory GHSA-3xc7-xg67-pw99 lists affected ranges: npm sequelize-cli >=0 <=5.4.0)

Commands are suggestions: review each one before running it.

Loading voting…