ZendOpenID potential security issue in login mechanism
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendopenid 2.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zendframework/zendopenid
- Affected
- >= 2.0.0, < 2.0.2
- Fixed in
- 2.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3x57-m5p4-rgh4 lists affected ranges: Packagist zendframework/zendopenid >=2.0.0 <2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Using the Consumer component of ZendOpenId (or ZendOpenId in ZF1), it is possible to login using an arbitrary OpenID account (without knowing any secret information) by using a malicious OpenID Provider. That means OpenID it is possible to login using arbitrary OpenID Identity (MyOpenID, Google, etc), which are not under the control of our own OpenID Provider. Thus, we are able to impersonate any OpenID Identity against the framework. Moreover, the Consumer accepts OpenID tokens with arbitrary signed elements. The framework does not check if, for example, both openid.claimedid and openid.endpointurl are signed. It is just sufficient to sign one parameter. According to https://openid.net/specs/openid-authentication-20.html#positiveassertions, at least opendpoint, returnto, responsenonce, assochandle, and, if present in the response, claimedid and identity, must be signed.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3x57-m5p4-rgh4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-3x57-m5p4-rgh4 Advisory: ZendOpenID potential security issue in login mechanism IDs: GHSA-3x57-m5p4-rgh4 Record: https://patchnext.com/advisories/ghsa-3x57-m5p4-rgh4 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zendframework/zendopenid 2.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zendframework/zendopenid: affected >= 2.0.0, < 2.0.2; fixed in 2.0.2 ## Suggested inspection (read-only) - Packagist zendframework/zendopenid: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zendframework/zendopenid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3x57-m5p4-rgh4 (GitHub-reviewed advisory GHSA-3x57-m5p4-rgh4 lists affected ranges: Packagist zendframework/zendopenid >=2.0.0 <2.0.2) Commands are suggestions: review each one before running it.
Loading voting…