laravel-crud-wizard-free has File Validation Bypass
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (macropay-solutions/laravel-crud-wizard-free 3.4.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist macropay-solutions/laravel-crud-wizard-free
- Affected
- < 3.4.17
- Fixed in
- 3.4.17
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3wgq-h4fr-cwg5 lists affected ranges: Packagist macropay-solutions/laravel-crud-wizard-free >=0 <3.4.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Medium Patches Version 3.4.17 fixes illuminate/validation v 8.0.0 to 11.44.0 Workarounds Register \MacropaySolutions\LaravelCrudWizard\Providers\ValidationServiceProvider instead of Illuminate\Validation\ValidationServiceProvider::class if you are using illuminate/validation < 11.44.1 References https://github.com/laravel/framework/security/advisories/GHSA-78fx-h6xr-vch4
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3wgq-h4fr-cwg5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-3wgq-h4fr-cwg5 Advisory: laravel-crud-wizard-free has File Validation Bypass IDs: GHSA-3wgq-h4fr-cwg5 Record: https://patchnext.com/advisories/ghsa-3wgq-h4fr-cwg5 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: macropay-solutions/laravel-crud-wizard-free 3.4.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist macropay-solutions/laravel-crud-wizard-free: affected < 3.4.17; fixed in 3.4.17 ## Suggested inspection (read-only) - Packagist macropay-solutions/laravel-crud-wizard-free: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on macropay-solutions/laravel-crud-wizard-free. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3wgq-h4fr-cwg5 (GitHub-reviewed advisory GHSA-3wgq-h4fr-cwg5 lists affected ranges: Packagist macropay-solutions/laravel-crud-wizard-free >=0 <3.4.17) Commands are suggestions: review each one before running it.
Loading voting…