Skip to content

← Actionable
High, CVSS 8.1

Using JMSAppender in log4j configuration may lead to deserialization of untrusted data

GHSA-3w6p-8f82-gw8r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ru.yandex.clickhouse:clickhouse-jdbc-bridge 2.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact ClickHouse JDBC Bridge uses slf4j-log4j12 1.7.32, which depends on log4j 1.2.17. It allows a remote attacker to execute code on the server, if you changed default log4j configuration by adding JMSAppender and an insecure JMS broker. Patches The patch version 2.0.7 removed log4j dependency by replacing slf4j-log4j12 to slf4j-jdk14. Logging configuration is also changed from log4j.properties to logging.properties. Workarounds 1. Do NOT change log4j configuration to use JMSAppender along with insecure JMS broker 2. Alternatively, you can issue below command to remove JMSAppender.class: References Please refer to CVE-2021-4104 to read more. For more information If you have any questions or comments about this advisory, please feel free to open an issue in the repository.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3w6p-8f82-gw8r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-3w6p-8f82-gw8r

Advisory: Using JMSAppender in log4j configuration may lead to deserialization of untrusted data
IDs: GHSA-3w6p-8f82-gw8r
Record: https://patchnext.com/advisories/ghsa-3w6p-8f82-gw8r (revision 1, source checked 26 Oct 2026, 15:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ru.yandex.clickhouse:clickhouse-jdbc-bridge 2.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven ru.yandex.clickhouse:clickhouse-jdbc-bridge: affected < 2.0.7; fixed in 2.0.7

## Suggested inspection (read-only)
- Maven ru.yandex.clickhouse:clickhouse-jdbc-bridge: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ru.yandex.clickhouse:clickhouse-jdbc-bridge.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3w6p-8f82-gw8r (GitHub-reviewed advisory GHSA-3w6p-8f82-gw8r lists affected ranges: Maven ru.yandex.clickhouse:clickhouse-jdbc-bridge >=0 <2.0.7)

Commands are suggestions: review each one before running it.

Loading voting…