Skip to content

← Actionable
Unrated

eZ Publish Remote code execution in file uploads

GHSA-3vwr-jj4f-h98x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezpublish-kernel 7.5.6.2, 6.13.6.2, 5.4.14.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist ezsystems/ezpublish-kernel

    Affected
    >= 7.5.0, < 7.5.6.2>= 6.13.0, < 6.13.6.2>= 5.4.0, < 5.4.14.1
    Fixed in
    6.13.6.2, 5.4.14.1, 7.5.6.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

This Security Advisory is about a vulnerability in the way eZ Platform and eZ Publish Legacy handles file uploads, which can in the worst case lead to remote code execution (RCE), a very serious threat. An attacker would need access to uploading files to be able to exploit the vulnerability, so if you have strict controls on this and trust all who have this permission, you're not affected. On the basis of the tests we have made, we also believe the vulnerability cannot be exploited as long as our recommended vhost configuration is used. Here is the v2.5 recommendation for Nginx, as an example: https://github.com/ezsystems/ezplatform/blob/2.5/doc/nginx/vhost.template#L31 This vhost template specifies that only the file app.php in the web root is executed, while vulnerable configurations allow execution of any php file. Apache is affected in the same way as Nginx, and is also protected by using the recommended configuration. The build-in webserver in PHP stays vulnerable, as it doesn't…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3vwr-jj4f-h98x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-3vwr-jj4f-h98x

Advisory: eZ Publish Remote code execution in file uploads
IDs: GHSA-3vwr-jj4f-h98x
Record: https://patchnext.com/advisories/ghsa-3vwr-jj4f-h98x (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezpublish-kernel 7.5.6.2, 6.13.6.2, 5.4.14.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist ezsystems/ezpublish-kernel: affected >= 7.5.0, < 7.5.6.2; >= 6.13.0, < 6.13.6.2; >= 5.4.0, < 5.4.14.1; fixed in 6.13.6.2, 5.4.14.1, 7.5.6.2

## Suggested inspection (read-only)
- Packagist ezsystems/ezpublish-kernel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ezsystems/ezpublish-kernel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3vwr-jj4f-h98x (GitHub-reviewed advisory GHSA-3vwr-jj4f-h98x lists affected ranges: Packagist ezsystems/ezpublish-kernel >=7.5.0 =6.13.0 =5.4.0 <5.4.14.1)

Commands are suggestions: review each one before running it.

Loading voting…