curl_cffi bundles a version of libcurl affected by High Severity vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (curl-cffi 0.7.0b6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI curl-cffi
- Affected
- <= 0.6.4
- Fixed in
- 0.7.0b6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3vpc-4p9p-47hc lists affected ranges: PyPI curl-cffi >=0 <0.7.0b6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3vpc-4p9p-47hc lists affected ranges: PyPI curl-cffi >=0 <=0.6.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary curlcffi is potentially affected by High Severity vulnerability (CVE-2023-38545) in libcurl<8.4.0 Details HIGH severity vulnerability in curl and libcurl: announcement Details are still unknown, but seems it will be a major issue as it's advertised by curl devs as "probably the worst curl security flaw in a long time". A patched version (8.4.0) and details will be published around 06:00 UTC on October 11. curlcffi wheels on PyPI ship with libcurl 7.84.0 PoC https://inspector.pypi.io/project/curl-cffi/0.5.10b2/packages/56/ae/eb7d39ad234f1f44650b910757d5aa696feff413d327c8328223ce78cb76/curlcffi-0.5.10b2-cp37-abi3-manylinux217aarch64.manylinux2014aarch64.whl/curlcffi/include/curl/curlver.h Resolution Versions after 0.7 bundles with libcurl=8.5, which is not affected by this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3vpc-4p9p-47hc
- Revision 1 · created ·
Published from osv record GHSA-3vpc-4p9p-47hc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-3vpc-4p9p-47hc Advisory: curl_cffi bundles a version of libcurl affected by High Severity vulnerability IDs: GHSA-3vpc-4p9p-47hc Record: https://patchnext.com/advisories/ghsa-3vpc-4p9p-47hc (revision 2, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: curl-cffi 0.7.0b6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI curl-cffi: affected <= 0.6.4; fixed in 0.7.0b6 ## Suggested inspection (read-only) - `python -m pip show curl-cffi`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on curl-cffi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3vpc-4p9p-47hc (OSV record GHSA-3vpc-4p9p-47hc lists affected ranges: PyPI curl-cffi >=0 <0.7.0b6 (fixed)) - Verified: https://github.com/advisories/GHSA-3vpc-4p9p-47hc (GitHub-reviewed advisory GHSA-3vpc-4p9p-47hc lists affected ranges: PyPI curl-cffi >=0 <=0.6.4) Commands are suggestions: review each one before running it.
Loading voting…