Skip to content

← Actionable
Unratedamended

yt-dlp has dependency on potentially malicious third-party code in Douyu extractors

GHSA-3v33-3wmw-3785

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yt-dlp 2024.7.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI yt-dlp

    Affected
    >= 2023.9.24, < 2024.7.7
    Fixed in
    2024.7.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact yt-dlp's DouyuTV and DouyuShow extractors used a cdn.bootcdn.net URL as a fallback for fetching a component of the crypto-js JavaScript library. When the Douyu extractor is used, yt-dlp extracts this JavaScript code and attempts to execute it externally using PhantomJS. bootcdn.net is owned by the bad actor responsible for the Polyfill JS supply chain attack that has been ongoing since at least June 2023. While there is no evidence that PhantomJS has been targeted by or is vulnerable to any attacks carried out by the Polyfill JS actor, there is the possibility that malicious JavaScript code may have been downloaded/cached by yt-dlp or executed by PhantomJS. In order for this potential vulnerability to be exploited by any hypothetical attack, all 3 of the following conditions must be met: 1. The user has PhantomJS installed on their system. 2. The user passes a douyu.com or douyutv.com URL to yt-dlp as input, or passes a URL that redirects to one of these domains. 3.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3v33-3wmw-3785

  2. Revision 1 · created ·

    Published from osv record GHSA-3v33-3wmw-3785

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-3v33-3wmw-3785

Advisory: yt-dlp has dependency on potentially malicious third-party code in Douyu extractors
IDs: GHSA-3v33-3wmw-3785
Record: https://patchnext.com/advisories/ghsa-3v33-3wmw-3785 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yt-dlp 2024.7.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI yt-dlp: affected >= 2023.9.24, < 2024.7.7; fixed in 2024.7.7

## Suggested inspection (read-only)
- `python -m pip show yt-dlp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yt-dlp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3v33-3wmw-3785 (OSV record GHSA-3v33-3wmw-3785 lists affected ranges: PyPI yt-dlp >=2023.09.24 <2024.07.07 (fixed))
- Verified: https://github.com/advisories/GHSA-3v33-3wmw-3785 (GitHub-reviewed advisory GHSA-3v33-3wmw-3785 lists affected ranges: PyPI yt-dlp >=2023.9.24 <2024.7.7)

Commands are suggestions: review each one before running it.

Loading voting…