Skip to content

← Actionable
High, CVSS 7.5

SurrealDB Affected by Confused Deputy Privilege Escalation through Future Fields and Functions

GHSA-3v2x-9xcv-2v2v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb 3.0.0-beta.3, 2.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io surrealdb

    Affected
    < 2.5.0>= 3.0.0-alpha.1, < 3.0.0-beta.3
    Fixed in
    3.0.0-beta.3, 2.5.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Unprivileged users (for example, those with the database editor role) can create or modify fields in records that contain functions or futures. Futures are values which are only computed when the value is queried. The query executes in the context of the querying user, rather than the user who originally defined the future. Likewise, fields containing functions or custom-defined logic (closures) are executed under the privileges of the invoking user, not the creator. This results in a confused deputy vulnerability: an attacker with limited privileges can define a malicious function or future field that performs privileged actions. When a higher-privileged user (such as a root owner or namespace administrator) executes the function or queries or modifies that record, the function executes with their elevated permissions. Impact An attacker who can create or update function/future fields can plant logic that executes with a privileged user’s context. If a privileged user performs a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3v2x-9xcv-2v2v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-3v2x-9xcv-2v2v

Advisory: SurrealDB Affected by Confused Deputy Privilege Escalation through Future Fields and Functions
IDs: GHSA-3v2x-9xcv-2v2v
Record: https://patchnext.com/advisories/ghsa-3v2x-9xcv-2v2v (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: surrealdb 3.0.0-beta.3, 2.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io surrealdb: affected < 2.5.0; >= 3.0.0-alpha.1, < 3.0.0-beta.3; fixed in 3.0.0-beta.3, 2.5.0

## Suggested inspection (read-only)
- crates.io surrealdb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on surrealdb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3v2x-9xcv-2v2v (GitHub-reviewed advisory GHSA-3v2x-9xcv-2v2v lists affected ranges: crates.io surrealdb >=0 =3.0.0-alpha.1 <3.0.0-beta.3)

Commands are suggestions: review each one before running it.

Loading voting…