Skip to content

← Actionable
High, CVSS 8.2amended

Redwood is vulnerable to account takeover via dbAuth "forgot-password"

GHSA-3qmc-2r76-4rqp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@redwoodjs/api 3.3.1, 2.2.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @redwoodjs/api

    Affected
    >= 0.38.0, < 2.2.5>= 3.0.0, < 3.3.1
    Fixed in
    3.3.1, 2.2.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? This is an API vulnerability in Redwood's [dbAuth], specifically the dbAuth forgot password feature: - only projects with the dbAuth "forgot password" feature are affected - this vulnerability was introduced in v0.38.0 User Accounts are Vulnerable to Takeover (Hijacking) A reset token for any user can be obtained given knowledge of their username or email via the forgot-password API. With the leaked reset token, a malicious user could request to reset a user's password, changing their credentials and gaining access to their account. How to Determine if Projects have been Attacked To determine if a project has been attacked, we recommend checking logs for suspicious activity; namely, the volume of requests to the forgot-password API using emails that don't exist. Another indication is if users inform you that they can't access their accounts. If you have question or concerns, reach out via the "For More Information" section…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3qmc-2r76-4rqp

  2. Revision 1 · created ·

    Published from osv record GHSA-3qmc-2r76-4rqp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-3qmc-2r76-4rqp

Advisory: Redwood is vulnerable to account takeover via dbAuth "forgot-password"
IDs: GHSA-3qmc-2r76-4rqp
Record: https://patchnext.com/advisories/ghsa-3qmc-2r76-4rqp (revision 2, source checked 26 Oct 2026, 12:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @redwoodjs/api 3.3.1, 2.2.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @redwoodjs/api: affected >= 0.38.0, < 2.2.5; >= 3.0.0, < 3.3.1; fixed in 3.3.1, 2.2.5

## Suggested inspection (read-only)
- `npm ls @redwoodjs/api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @redwoodjs/api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3qmc-2r76-4rqp (OSV record GHSA-3qmc-2r76-4rqp lists affected ranges: npm @redwoodjs/api >=0.38.0 =3.0.0 <3.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-3qmc-2r76-4rqp (GitHub-reviewed advisory GHSA-3qmc-2r76-4rqp lists affected ranges: npm @redwoodjs/api >=0.38.0 =3.0.0 <3.3.1)

Commands are suggestions: review each one before running it.

Loading voting…