Paperclip: Arbitrary File Read via Agent-Controlled adapterConfig.instructionsFilePath
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@paperclipai/shared 2026.416.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2026.416.0
- Fixed in
- 2026.416.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3pw3-v88x-xj24 lists affected ranges: npm @paperclipai/shared >=0 <2026.416.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3pw3-v88x-xj24 lists affected ranges: npm @paperclipai/shared >=0 <2026.416.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Paperclip contains an arbitrary file read vulnerability that allows an attacker with an Agent API key to read files from the Paperclip server host filesystem. The vulnerability occurs because agents are allowed to modify their own adapterConfig through the /agents/:id API endpoint. The configuration field adapterConfig.instructionsFilePath is later read directly by the server runtime using fs.readFile(). Because no validation or path restriction is applied, an attacker can supply an arbitrary filesystem path. The Paperclip server then attempts to read that path from the host filesystem during agent execution. This breaks the intended trust boundary between agent runtime configuration and server host filesystem access, allowing a compromised or malicious agent to access sensitive files on the host system. Details Root Cause No path normalization, allowlist, or workspace boundary validation is applied before the filesystem read occurs. Agent configuration can be modified…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3pw3-v88x-xj24
- Revision 1 · created ·
Published from osv record GHSA-3pw3-v88x-xj24
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-3pw3-v88x-xj24 Advisory: Paperclip: Arbitrary File Read via Agent-Controlled adapterConfig.instructionsFilePath IDs: GHSA-3pw3-v88x-xj24 Record: https://patchnext.com/advisories/ghsa-3pw3-v88x-xj24 (revision 2, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @paperclipai/shared 2026.416.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @paperclipai/shared: affected < 2026.416.0; fixed in 2026.416.0 ## Suggested inspection (read-only) - `npm ls @paperclipai/shared --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @paperclipai/shared. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3pw3-v88x-xj24 (OSV record GHSA-3pw3-v88x-xj24 lists affected ranges: npm @paperclipai/shared >=0 <2026.416.0 (fixed)) - Verified: https://github.com/advisories/GHSA-3pw3-v88x-xj24 (GitHub-reviewed advisory GHSA-3pw3-v88x-xj24 lists affected ranges: npm @paperclipai/shared >=0 <2026.416.0) Commands are suggestions: review each one before running it.
Loading voting…