GraphQL queries can expose password hashes
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ibexa/graphql 4.2.3, 3.3.28, 2.5.31), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ibexa/graphql
- Affected
- >= 2.5.0, < 2.5.31>= 4.2.0, < 4.2.3>= 3.3.0, < 3.3.28
- Fixed in
- 3.3.28, 2.5.31, 4.2.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3p7g-wrgg-wq45 lists affected ranges: Packagist ibexa/graphql >=2.5.0 =4.2.0 =3.3.0 <3.3.28
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Unauthenticated GraphQL queries for user accounts can expose password hashes of users that have created or modified content, typically but not necessarily limited to administrators and editors. Patches Affected versions: Ibexa DXP v3.3.\, v4.2.\, eZ Platform v2.5.\ Resolving versions: Ibexa DXP v3.3.28, v4.2.3, eZ Platform v2.5.31 Workarounds Remove the "passwordHash" entry from "src/bundle/Resources/config/graphql/User.types.yaml" in the GraphQL package, and other properties like hash type, email, login if you prefer. References This issue was reported to us by Philippe Tranca ("trancap") of the company Lexfo. We are very grateful for their research, and responsible disclosure to us of this critical vulnerability. For more information If you have any questions or comments about this advisory, please contact Support via your service portal.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3p7g-wrgg-wq45
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-3p7g-wrgg-wq45 Advisory: GraphQL queries can expose password hashes IDs: GHSA-3p7g-wrgg-wq45 Record: https://patchnext.com/advisories/ghsa-3p7g-wrgg-wq45 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ibexa/graphql 4.2.3, 3.3.28, 2.5.31. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ibexa/graphql: affected >= 2.5.0, < 2.5.31; >= 4.2.0, < 4.2.3; >= 3.3.0, < 3.3.28; fixed in 3.3.28, 2.5.31, 4.2.3 ## Suggested inspection (read-only) - Packagist ibexa/graphql: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ibexa/graphql. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3p7g-wrgg-wq45 (GitHub-reviewed advisory GHSA-3p7g-wrgg-wq45 lists affected ranges: Packagist ibexa/graphql >=2.5.0 =4.2.0 =3.3.0 <3.3.28) Commands are suggestions: review each one before running it.
Loading voting…