Skip to content

← Actionable
High, CVSS 7.5

Silverstripe SiteTree Creation Permission Vulnerability

GHSA-3mm9-2p44-rw39

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/cms 3.1.11, 3.0.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist silverstripe/cms

    Affected
    >= 3.0.0, <= 3.0.11>= 3.1.0, < 3.1.11
    Fixed in
    3.1.11, 3.0.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

A vulnerability exists in the permission validation for SiteTree object creation. By default user permissions are not validated by the SiteTree::canCreate method, unless overridden by user code or via the configuration system. This vulnerability will allow users, or unauthenticated guests, to create new SiteTree objects in the database. This vulnerability is present when such users are given CMS access via other means, or if there is another mechanism (such as RestfulServer module) which allows model editing and relies on model-level permission checks. This vulnerability is restricted to the creation of draft or live pages, and does not allow users to edit, publish, or unpublish existing pages. All users should upgrade as soon as possible.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3mm9-2p44-rw39

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-3mm9-2p44-rw39

Advisory: Silverstripe SiteTree Creation Permission Vulnerability
IDs: GHSA-3mm9-2p44-rw39
Record: https://patchnext.com/advisories/ghsa-3mm9-2p44-rw39 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/cms 3.1.11, 3.0.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/cms: affected >= 3.0.0, <= 3.0.11; >= 3.1.0, < 3.1.11; fixed in 3.1.11, 3.0.12

## Suggested inspection (read-only)
- Packagist silverstripe/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3mm9-2p44-rw39 (GitHub-reviewed advisory GHSA-3mm9-2p44-rw39 lists affected ranges: Packagist silverstripe/cms >=3.0.0 =3.1.0 <3.1.11)

Commands are suggestions: review each one before running it.

Loading voting…