@grackle-ai/server has Missing Content-Security-Policy and X-Frame-Options Headers
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@grackle-ai/server 0.70.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 0.70.3
- Fixed in
- 0.70.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3mjm-x6gw-2x42 lists affected ranges: npm @grackle-ai/server >=0 <0.70.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3mjm-x6gw-2x42 lists affected ranges: npm @grackle-ai/server >=0 <=0.70.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact The HTTP server does not set Content-Security-Policy, X-Frame-Options, or X-Content-Type-Options headers on any response. This reduces defense-in-depth against XSS, clickjacking, and MIME-sniffing attacks. While the current XSS attack surface is small (React-markdown is configured safely, no dangerouslySetInnerHTML, Vite does not generate source maps), the absence of these headers means any future XSS vulnerability would have no secondary defense layer. Affected code: - packages/server/src/index.ts — all res.writeHead() calls only set Content-Type, with no security headers Patches 0.70.4 Fix: Add security headers to all HTML/API responses: Workarounds Use a reverse proxy (nginx, Caddy) in front of the Grackle server to inject security headers. References - CWE-693: Protection Mechanism Failure - OWASP: HTTP Security Response Headers - File: packages/server/src/index.ts
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3mjm-x6gw-2x42
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-3mjm-x6gw-2x42
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-3mjm-x6gw-2x42 Advisory: @grackle-ai/server has Missing Content-Security-Policy and X-Frame-Options Headers IDs: GHSA-3mjm-x6gw-2x42 Record: https://patchnext.com/advisories/ghsa-3mjm-x6gw-2x42 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @grackle-ai/server 0.70.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @grackle-ai/server: affected <= 0.70.3; fixed in 0.70.4 ## Suggested inspection (read-only) - `npm ls @grackle-ai/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @grackle-ai/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3mjm-x6gw-2x42 (OSV record GHSA-3mjm-x6gw-2x42 lists affected ranges: npm @grackle-ai/server >=0 <0.70.4 (fixed)) - Verified: https://github.com/advisories/GHSA-3mjm-x6gw-2x42 (GitHub-reviewed advisory GHSA-3mjm-x6gw-2x42 lists affected ranges: npm @grackle-ai/server >=0 <=0.70.3) Commands are suggestions: review each one before running it.
Loading voting…