Gitea has insecure default SSH settings
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (code.gitea.io/gitea 1.25.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.25.0
- Fixed in
- 1.25.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3m6q-h5gj-7mrw lists affected ranges: Go code.gitea.io/gitea >=0 <1.25.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary The built-in SSH server currently advertises a number of key exchange, MAC, and host key algorithms that are considered weak or broken. The defaults should be tightened so a fresh installation passes a baseline SSH security audit out of the box. Details Running ssh-audit against a default deployment flags the following as fail: - Key exchange - ecdh-sha2-nistp256 - ecdh-sha2-nistp384 - ecdh-sha2-nistp521 - MAC - hmac-sha1 - Host key - ssh-rsa Reproduction Impact Default deployments expose algorithms that are known-weak or deprecated upstream. The current workaround requires manually setting several GITEAserverSSHSERVER variables, which most users will never do. Workaround There is no exposed option to restrict host key algorithms, so ssh-rsa remains advertised. Acceptance criteria - [ ] Default SSHSERVERKEYEXCHANGES, SSHSERVERCIPHERS, and SSHSERVERMACS updated to the secure list above. - [ ] New SSHSERVERHOSTKEYALGORITHMS option added, with a default that excludes ssh-rsa. -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3m6q-h5gj-7mrw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-3m6q-h5gj-7mrw Advisory: Gitea has insecure default SSH settings IDs: GHSA-3m6q-h5gj-7mrw Record: https://patchnext.com/advisories/ghsa-3m6q-h5gj-7mrw (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: code.gitea.io/gitea 1.25.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go code.gitea.io/gitea: affected < 1.25.0; fixed in 1.25.0 ## Suggested inspection (read-only) - Go code.gitea.io/gitea: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on code.gitea.io/gitea. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3m6q-h5gj-7mrw (GitHub-reviewed advisory GHSA-3m6q-h5gj-7mrw lists affected ranges: Go code.gitea.io/gitea >=0 <1.25.0) Commands are suggestions: review each one before running it.
Loading voting…