Skip to content

← Actionable
Critical, CVSS 9.8

Generated code can read and write out of bounds in safe code

GHSA-3jch-9qgp-4844

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flatbuffers 22.9.29), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Code generated by flatbuffers' compiler is unsafe but not marked as such. See https://github.com/google/flatbuffers/issues/6627 for details. All users that use generated code by flatbuffers compiler are recommended to: 1. not expose flatbuffer generated code as part of their public APIs 2. audit their code and look for any usage of follow, push, or any method that uses them (e.g. selffollow). 3. Carefuly go through the crates' documentation to understand which "safe" APIs are not intended to be used.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3jch-9qgp-4844

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-3jch-9qgp-4844

Advisory: Generated code can read and write out of bounds in safe code
IDs: GHSA-3jch-9qgp-4844
Record: https://patchnext.com/advisories/ghsa-3jch-9qgp-4844 (revision 1, source checked 26 Oct 2026, 15:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flatbuffers 22.9.29. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io flatbuffers: affected < 22.9.29; fixed in 22.9.29

## Suggested inspection (read-only)
- crates.io flatbuffers: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flatbuffers.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3jch-9qgp-4844 (GitHub-reviewed advisory GHSA-3jch-9qgp-4844 lists affected ranges: crates.io flatbuffers >=0 <22.9.29)

Commands are suggestions: review each one before running it.

Loading voting…