Stud42 vulnerable to denial of service
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (atomys.codes/stud42 0.23.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.23.0
- Fixed in
- 0.23.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3hwm-922r-47hw lists affected ranges: Go atomys.codes/stud42 >=0 <0.23.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
A security vulnerability has been identified in the GraphQL parser used by the API of s42.app. An attacker can overload the parser and cause the API pod to crash. With a bit of threading, the attacker can bring down the entire API, resulting in an unhealthy stream. This vulnerability can be exploited by sending a specially crafted request to the API with a large payload. An attacker can exploit this vulnerability to cause a denial of service (DoS) attack on the s42.app API, resulting in unavailability of the API for legitimate users.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3hwm-922r-47hw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-3hwm-922r-47hw Advisory: Stud42 vulnerable to denial of service IDs: GHSA-3hwm-922r-47hw Record: https://patchnext.com/advisories/ghsa-3hwm-922r-47hw (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: atomys.codes/stud42 0.23.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go atomys.codes/stud42: affected < 0.23.0; fixed in 0.23.0 ## Suggested inspection (read-only) - Go atomys.codes/stud42: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on atomys.codes/stud42. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3hwm-922r-47hw (GitHub-reviewed advisory GHSA-3hwm-922r-47hw lists affected ranges: Go atomys.codes/stud42 >=0 <0.23.0) Commands are suggestions: review each one before running it.
Loading voting…