Skip to content

← Actionable
Medium, CVSS 5.3amended

Tornado: Unbounded query-string argument count allows event-loop-stalling DoS

CVE-2026-103261GHSA-3hv7-mjh2-fv65

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tornado 6.5.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tornado

    Affected
    <= 6.5.8
    Fixed in
    6.5.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-103261: 0.47% estimated exploitation activity in the next 30 days; percentile 40.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary HTTPServerRequest.init in tornado/httputil.py parses the URL query string via parseqsbytes() with no field-count limit — while the sibling POST-body parsing path (parsebodyarguments) received a maxnumfields=1000 cap added earlier in this exact same release (v6.5.8, commit 8d6363ed), explicitly to bound parsing cost for the identical underlying primitive. This leaves the query-string path with the resource-exhaustion exposure the body-path fix was meant to close. File: tornado/httputil.py, line 553 (HTTPServerRequest.init) Root Cause Compare with the POST-body path fixed one commit earlier in the same release: Both call sites funnel through the same tornado.escape.parseqsbytes (a thin wrapper over urllib.parse.parseqs), which is exactly why maxnumfields was added to urllib.parse.parseqsl upstream — to let frameworks bound field count. The fix was applied only to the body path; the query-string path was missed. The request line + headers together are capped at maxheadersize…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3hv7-mjh2-fv65

  2. Revision 2 · amended ·

    Amended from osv record GHSA-3hv7-mjh2-fv65

  3. Revision 1 · created ·

    Published from ghsa record GHSA-3hv7-mjh2-fv65

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-103261

Advisory: Tornado: Unbounded query-string argument count allows event-loop-stalling DoS
IDs: CVE-2026-103261, GHSA-3hv7-mjh2-fv65
Record: https://patchnext.com/advisories/ghsa-3hv7-mjh2-fv65 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tornado 6.5.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tornado: affected <= 6.5.8; fixed in 6.5.9

## Suggested inspection (read-only)
- `python -m pip show tornado`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tornado.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3hv7-mjh2-fv65 (GitHub-reviewed advisory GHSA-3hv7-mjh2-fv65 lists affected ranges: PyPI tornado >=0 <=6.5.8)
- Verified: https://osv.dev/vulnerability/GHSA-3hv7-mjh2-fv65 (OSV record GHSA-3hv7-mjh2-fv65 lists affected ranges: PyPI tornado >=0 <6.5.9 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…