Axios supply chain attack - dependency in @lightdash/cli may resolve to compromised axios versions
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@lightdash/cli 0.2695.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @lightdash/cli
- Affected
- >= 0.1800.0, < 0.2695.1
- Fixed in
- 0.2695.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3hfp-gqgh-xc5g lists affected ranges: npm @lightdash/cli >=0.1800.0 <0.2695.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3hfp-gqgh-xc5g lists affected ranges: npm @lightdash/cli >=0.1800.0 <0.2695.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact A supply chain attack on the axios npm package (versions 1.14.1 and 0.30.4) introduced a malicious transitive dependency (plain-crypto-js@4.2.1) that deploys a cross-platform remote access trojan (RAT) on macOS, Windows, and Linux. The attacker compromised the primary axios maintainer's npm account to publish the malicious versions. The malicious versions were live on npm for approximately 3 hours (00:21 UTC to 03:29 UTC on March 31, 2026) before being removed. The @lightdash/cli package specified axios as a dependency with a semver range (^1.12.0) that permitted resolution to the compromised version. Any user who performed a fresh install of @lightdash/cli versions = 0.1800.0, < 0.2695.1 (without a pre-existing lockfile) during this window may have installed the malicious axios version. If compromised, the RAT establishes a connection to a command-and-control server (sfrclak[.]com / 142.11.206.73:8000) and provides the attacker with shell access, file system enumeration, and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3hfp-gqgh-xc5g
- Revision 2 · amended ·
Amended from osv record GHSA-3hfp-gqgh-xc5g
- Revision 1 · created ·
Published from ghsa record GHSA-3hfp-gqgh-xc5g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-3hfp-gqgh-xc5g Advisory: Axios supply chain attack - dependency in @lightdash/cli may resolve to compromised axios versions IDs: GHSA-3hfp-gqgh-xc5g Record: https://patchnext.com/advisories/ghsa-3hfp-gqgh-xc5g (revision 3, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @lightdash/cli 0.2695.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @lightdash/cli: affected >= 0.1800.0, < 0.2695.1; fixed in 0.2695.1 ## Suggested inspection (read-only) - `npm ls @lightdash/cli --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @lightdash/cli. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3hfp-gqgh-xc5g (GitHub-reviewed advisory GHSA-3hfp-gqgh-xc5g lists affected ranges: npm @lightdash/cli >=0.1800.0 <0.2695.1) - Verified: https://osv.dev/vulnerability/GHSA-3hfp-gqgh-xc5g (OSV record GHSA-3hfp-gqgh-xc5g lists affected ranges: npm @lightdash/cli >=0.1800.0 <0.2695.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…