Graby has stored XSS via iframe srcdoc Attribute in htmLawed Sanitization Config
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (j0k3r/graby 2.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist j0k3r/graby
- Affected
- <= 2.5.0
- Fixed in
- 2.5.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3h6j-9x8m-rg3g lists affected ranges: Packagist j0k3r/graby >=0 <=2.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Graby's cleanupXss() function configures htmLawed with conflicting settings: safe=1 (which removes <iframe) combined with 'elements' = '+iframe-meta' (which re-enables <iframe). htmLawed does not sanitize the srcdoc attribute, allowing injection of arbitrary JavaScript that executes when the content is rendered via |raw in templates. Root Cause src/Graby.php lines 1038-1048: The safe=1 and +iframe combination is a conflict: safe mode is designed to strip dangerous elements, but the elements override re-enables <iframe without also blocking the dangerous srcdoc attribute. Proof of Concept Input to cleanupXss(): Output (unchanged — htmLawed passes it through): When rendered via {{ content|raw }} in a template, srcdoc executes in an about:srcdoc frame with the same origin as the page. Confirmed via Puppeteer/Chromium headless: alert(document.domain) fires. Validated on Wallabag (which uses Graby) via Docker: entry created via API with iframe-only content body triggers…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3h6j-9x8m-rg3g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-3h6j-9x8m-rg3g Advisory: Graby has stored XSS via iframe srcdoc Attribute in htmLawed Sanitization Config IDs: GHSA-3h6j-9x8m-rg3g Record: https://patchnext.com/advisories/ghsa-3h6j-9x8m-rg3g (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: j0k3r/graby 2.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist j0k3r/graby: affected <= 2.5.0; fixed in 2.5.1 ## Suggested inspection (read-only) - Packagist j0k3r/graby: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on j0k3r/graby. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3h6j-9x8m-rg3g (GitHub-reviewed advisory GHSA-3h6j-9x8m-rg3g lists affected ranges: Packagist j0k3r/graby >=0 <=2.5.0) Commands are suggestions: review each one before running it.
Loading voting…